Программа мониторинга "Автосенсор"

V.1.2.0 		Top Next

Программа предназначена для считывания данных из памяти датчиков "Автосенсор", их последующей обработки и формирования отчетов.

Для считывания данных Вам понадобится USB-радиосчитыватель.

Возможности программы позволяют:

- вести эффективный контроль за автотехникой на малых предприятиях;

- эффективно решать спорные ситуации, когда есть сомнения в достоверности данных, передаваемых терминалом (глушение GPS сигнала, отключение терминала и т.д.).


Подключение файла справки и определение его версии

V.1.2.0 		Top Previous Next

1. Подключение файла справки

Программа имеет встроенную "СПРАВКУ" (HELP).

Файл справки имеет достаточно большой размер, поэтому он доступен для скачивания отдельно от программы.
Скачать файл справки можно по адресу: http://avtosensor.ru/?page_id=4541

Программа поддерживает типы справок, имеющие расширения: *.pdf , *.exe и *.chm.

Имена русскоязычных файлов справки:

ML_rus.chm

ML_rus.exe

ML_rus.pdf

Для подключения файла справки к программе необходимо:

1.Скачайте с сайта файл справки в удобном для Вас формате.
Файл ML_rus.chm - стандартный формат справки Windows. Будет доступен на всех компьютерах. Имеет большой размер.
Файл ML_rus.exe - будет доступен на всех компьютерах. Имеет большой размер.
Файл ML_rus.pdf - имеет меньший размер, но требует установки программы-просмотрщика файлов *.pdf.

2.Разместите один из файлов справки в каталоге (директории) по адресу: "Каталог размещения исполнительного файла программы\HELP\"

Файл справки станет доступным при нажатии в программе клавиши "F1", или через раздел главного меню программы: "Справка - Помощь (F1)".

2. Определение версии файла справки

Мы постоянно совершенствуем свои продукты. Вместе с этим, вносятся изменения в файл справки.
Пожалуйста убедитесь, что Вы используете последнюю версию файла справки. Это поможет Вам, в полной мере, использовать технические возможности нашей продукции.

Версия файла справки указана:

Для файлов *.chm

Для файлов *.exe

Для файлов *.pdf

Для WEB-справки


Установка программы и подключение USB-Радиосчитывателя

Для установки программы на ПК необходимо выполнить следующие действия:

1. Скачайте программу с сайта производителя http://avtosensor.ru/?page_id=4541

2. Поместите скаченный файл в директорию (папку), путь к которой может состоять только из цифр и латинских букв.
ВНИМАНИЕ! В названии пути к папке с файлами программы могут использоваться только цифры и латинские буквы.

3. Запустите исполнительный файл программы. Программа готова к работе.


Подключение USB-радиосчитывателя

USB-радиосчитыватель служит для поиска радиоустройств "Автосенсор" и считывания данных из их архивов.

Статус USB-радиосчитывателя отображается в верхней части программы.

При первом подключении USB-радиосчитывателя к ПК, возможно, Вам придется установить драйвер.

Для установки драйвера USB-радиосчитывателя необходимо:

1. Скачать драйвер. Скачать драйвер на сайте "Автосенсор", перейдя по этой ссылке или на сайте производителя микросхемы "Silicon Labs USB to UART Bridge", перейдя по этой ссылке

2. Распаковать архив драйвера в любую папку.

3. Подсоединить USB-радиосчитыватель к персональному компьютеру.

4. В мастере нового оборудования, который появится автоматически, откажитесь от поиска драйвера в Интернете и нажмите кнопку “Далее”.

5. Выберите “Установка из указанного места”. Нажмите кнопку “Далее”.

6. Укажите папку, в которую Вы распаковали архив с драйвером. Нажмите кнопку “Далее”.

7. После установки драйвера, в “Диспетчере устройств”, в группе "Порты (COM и LPT) должно появиться новое устройство “Silicon Labs CP210x USB to UART Bridge”.

8. Установка завершена.


Обновление прошивки USB-радиосчитывателя

Для обновление прошивки USB-радиосчитывателя выполните следующие действия:

Кликните на статус USB-радиосчитывателя "Радиосчитыватель № ХХХ на COM ХХ". Статус радиосчитывателя указан в верхней части окна программы.

В открывшемся окне доступна информация об используемом радиосчитывателе и текущей версии его прошивки.

Для обновления прошивки радиосчитывателя необходимо:

1.Выбрать файл прошивки, нажав кнопку "Обзор файлов".

2.Нажать кнопку "Обновить".

Прошивка USB-радиосчитывателя будет обновлена.


Работа с программой

Интерфейс программы имеет четыре панели отображения информации:

- Панель отображения объектов.

На панели объектов отображается информация об объектах мониторинга:

·Панель поиска объектов. Вы можете находить объекты по любым ключевым словам, содержащихся в названии объекта.

·Кнопка "Считать данные" - служит для считывания данных с датчиков объекта. Кнопка дублируется значком на верхней панели инструментов. В момент считывания данных с датчиков, кнопка и значок на панели инструментов меняют свои названия на "Остановить считывание". При нажатии - считывание данных с датчиков прерывается.

·Название объекта - отображается название объекта, заданное пользователем.

·Актуальная дата считаных данных - показывает дату, до которой имеется информация об объекте.

·Текущее время датчиков объекта - показывает время внутренних часов датчиков, установленных на объекте. Если на объекте установено несколько датчиков, то все они будут иметь одинаковое время. Время датчиков, установленных на объекте, автоматически синхронизируется со временем датчика, имеющим наименьший номер,
ВНИМАНИЕ! Изменить время датчиков на объекте можно при помощи программы-конфигуратора. Если на объекте установлено несколько датчиков, то достаточно изменить время у датчика с наименьшим номером. Время остальных датчиков будет автоматически синхронизировано по датчику с наименьшим номером в момент считывания данных USB-радиосчитывателем.

- Панель отображения датчиков, установленных на объекте.

На панели датчиков отображается информация об установленных на объекте датчиков:

·Номер датчика - номер датчика, установленный на объекте.

·Идентификатор датчика - отображает тип датчика: датчик уровня топлива, датчик присутствия пассажира и т.п.

·Отображаемое имя - имя датчика, заданное пользователем. Это имя будет фигурировать во всех отчетах с использованием данного датчика.

- Панель анализируемой информации (отчеты).

\

На панели информармации имеется:

·Панель выбора временного интервала. Вы можете установить временной интервал, за который будет выведена вся информация об объекте.

·Информационные вкладки. Для удобства, информация разнесена по вкладкам. Количество вкладок зависит от типа датчиков, установленных на объекте, и от выбранных отчетов для объекта.

- Панель отображения графической информации.

На панели отображается информация в виде графиков.


Изменение размеров панелей отображения информации

Вы можете изменять размеры всех панелей с отображаемой информацией.

Для изменения размеров панелей, потяните мышкой за штриховые полоски, расположенные на границах панелей.

Установленные размеры панелей автоматически сохраняются.


Добавление, редактирование и удаление объектов

Для добавления объекта нажмите кнопку "Плюс" на верхней панели инструментов.

В открывшемся окне создания и редактирования объекта задайте его имя и нажмите кнопку "Ok".

Объект создан и отображается в списке объектов.

Для редактирования объекта - выберите объект и нажмите кнопку "Карандаш" на верхней панели инструментов. Откроется окно создания и редактирования объекта, которое описано выше. После завершения редактирования нажмите кнопку "Ok".

Для удаления объекта - выберите объект и нажмите кнопку "Крестик" на верхней панели инструментов. После подтверждения запроса на удаление - объект будет удален без возможности восстановления.

ВНИМАНИЕ! Удаление объекта происходит без возможности его восстановления. Вместе с объектом будут удалены все данные и настройки, относящиеся к этому объекту.


Управление датчиками объекта

Датчики объекта можно:

·Добавлять

·Удалять

·Редактировать

·Объединять

Добавление датчиков объекта.

Откройте окно редактирования объекта.

На вкладке "Подключенные датчики" установите номер радиоканала, на котором работают датчики на этом объекте.

ВНИМАНИЕ! Если на объекте установлено несколько датчиков, то все они должны работать на одном и том же радиоканала. Задать номер радиоканала датчика можно при помощи программы-конфигуратора.

·Нажмите кнопку "Добавить". В таблице добавится строка.

·Щелкните левой кнопкой мышки в ячейке "Тип датчика". Выбирите тип датчика из раскрывшегося списка.

·Дважды щелкните левой кнопкой мышки в ячейке "Серийный номер датчика". В появившемся поле редактирования укажите номер датчика.
ВНИМАНИЕ! Серийный номер датчика указан на этикетке датчика.

·Дважды щелкните левой кнопкой мышки в ячейке "Пароль на считывание архива". В появившемся поле редактирования укажите пароль на считывание архива.
ВНИМАНИЕ! Пароль на считывание архива задается в датчике при помощи программы-конфигуратора. По умолчанию, в датчиках не задан пароль, и не разрешено считывание архивных данных USB-радиосчитывателем.

·Дважды щелкните левой кнопкой мышки в ячейке "Отображаемое имя". В появившемся поле редактирования укажите удобное и понятное Вам имя датчика.

Датчик добавлен на объект.

Для добавления следующего датчика повторите вышеуказанные действия.

ВНИМАНИЕ! После завершения добавления датчиков нажмите кнопку "Ок" для сохранения сделанных Вами изменений.

Удаление датчиков объекта.

Откройте окно редактирования объекта. На вкладке "Подключенные датчики" выберите датчик. Нажмите кнопку "Удалить". После подтверждения запроса на удаление - датчик будет удален без вожмости восстановления.

ВНИМАНИЕ! Удаление датчика происходит без возможности его восстановления. Вместе с датчиком будут удалены все данные, относящиеся к этому датчику.
Если удаляемый датчик участововал в объединениях с другими датчиками - все такие объединения будут удалены.

ВНИМАНИЕ! После завершения удаления датчиков нажмите кнопку "Ок" для сохранения сделанных Вами изменений.

Редактирование датчиков объекта.

Откройте окно редактирования объекта. На вкладке "Подключенные датчики" произведите необходимые изменения.

·Для редактирования типа датчика щелкните левой кнопкой мышки в ячейке "Тип датчика". Измените тип датчика, выбрав новый тип из раскрывшегося списка.

·Для редактирования серийного номера датчика дважды щелкните левой кнопкой мышки в ячейке "Серийный номер датчика". В появившемся поле редактирования измените номер датчика.
ВНИМАНИЕ! Серийный номер датчика указан на этикетке датчика.

·Для редактирования пароля на считывание архива дважды щелкните левой кнопкой мышки в ячейке "Пароль на считывание архива". В появившемся поле редактирования измените пароль на считывание архива.
ВНИМАНИЕ! Пароль на считывание архива задается в датчике при помощи программы-конфигуратора. По умолчанию, в датчиках не задан пароль, и не разрешено считывание архивных данных USB-радиосчитывателем.

·Для редактирования отображаемого имени дважды щелкните левой кнопкой мышки в ячейке "Отображаемое имя". В появившемся поле редактирования укажите удобное и понятное Вам имя датчика.

ВНИМАНИЕ! После завершения редактирования датчиков нажмите кнопку "Ок" для сохранения сделанных Вами изменений.

Объединение датчиков объекта.

Однотипные датчики объекта могут быть объединены между собой. Это необходимо в случаях:

·в один топливный бак установлено более одного датчика уровня топлива, и мы хотим видеть среднее значение уровней топлива;

·на автомобиле установлены два сообщающихся топливных бака и мы хотим видеть сумму уровней топлива;

·в автобусе установлены 36 датчиков присутствия пассажира и мы хотим видет общее количество пассажиров.

Могут быть и другие случаи, когда необходимо объединять датчики.

Создание объединения.

Откройте окно редактирования объекта. Перейдите на вкладку "Объединенные датчики" и нажмите кнопку "Создать".

Откроется окно создания и редактирования объединений.

Окно имеет следующие элементы:

·Отображаемое имя - задается пользователем для идентификации создаваемого объединения.

·Тип датчиков - фильтр, при выборе которого, в таблице доступных к объединению датчиков, будут отображаться только номера датчиков выбранного типа.

·Доступные датчики - список номеров доступных для объединения датчиков.

Поставьте "галочки" напротив номеров датчиков, которые Вы хотите объединить между собой.

Нажмите кнопку "Добавить".

В окне редактирования объекта, на вкладке "Объединенные датчики" появится запись о созданном объединении.

ВНИМАНИЕ! После создания объединения нажмите кнопку "Ок" для сохранения сделанных Вами изменений.

Редактирование объединения.

Откройте окно редактирования объекта. Перейдите на вкладку "Объединенные датчики". Выберите в списке нужное Вам объединение и нажмите кнопку "Редактировать".

В открывшемся окне создания и редактирования объединений произведите необходимые изменения. Окно создания и редактирования объединений описано выше.

ВНИМАНИЕ! После редактирования объединения нажмите кнопку "Ок" для сохранения сделанных Вами изменений.

Удаление объединения.

Откройте окно редактирования объекта. Перейдите на вкладку "Объединенные датчики". Выберите в списке нужное Вам объединение и нажмите кнопку "Удалить". После подтверждения запроса на удаление - объединение будет удалено без возможности восстановления.

ВНИМАНИЕ! Удаление объединения происходит без возможности его восстановления. Вместе с объединением будут удалены все данные, относящиеся к этому объединению. Датчики, входящие в удаляемое объединение удалены не будут.
ВНИМАНИЕ! После удаления объединения нажмите кнопку "Ок" для сохранения сделанных Вами изменений.


Управление отображаемыми данными

Откройте окно редактирования объекта. На вкладке "Доступные данные" выберите данные, которые Вы хотите анализировать на графиках.

Выбранные Вами данные будут отображаться на графиках.
На график могут быть выведены как обычные, так и объединенные данные.

Для изменения цвета отображения данных на графике - кликнете левой кнопкой мышки на квадрате с цветом.


Управление отчетами

Отчеты можно:

·Добавлять.

·Удалять.

Для добавления отчета - откройте окно редактирования объекта.

На вкладке "Отчет" нажмите кнопку "Добавить отчет". Из выпадающего списку выберите нужный отчет.

Выбранный отчет появится в списке отчетов.

Кликните левой кнопкой мышки в ячейке "Источник". Из выпадающего списка выберите источник, с которого будут поступать данные в выбранный отчет.

Обратите внимание:
Количество отчетов "По топливу" не ограничено.

Остальные отчеты могут использовать только один источник.

Для удаления отчета - откройте окно редактирования объекта. Выберите удаляемый отчет. Нажмите кнопку "Удалить".

После подтверждения - отчет будет удален.


Работа с графиками

На график можно выводить и анализировать данные с датчиков.

Дважды кликните левой кнопкой мышки на графике.
Рядом с курсором, во всплывающем окне, отобразится информация, соответствующая временному расположению курсора.

По нажатию правой кнопки мышки появится меню:
- Отображать легенду - отображает/прячет легенду графика.

- Задать как начальную дату - задает как начальную дату, местоположение курсора.

- задать как конечную дату - задает как конечную дату, местоположение курсора.


Перенос программы на другой компьютер

Перенесите папку с программой на другой компьютер.

Программа готова к работе.


Копирование (резервирование) базы данных

Файлы базы данных программы располагаются по адресу: "Папка программы\Data\" и имеют расширения *.db.

Для резервирования базы данных просто скопируйте папку "Data" на любой носитель.


Примеры настроек отчетов для различных видов техники

Программа позволяет производить гибкие настройки для формирования отчетов по любым видам техники.


Техника с одним стандартным топливным баком

Имеем: автомобиль с одним топливным баком.

Можем контролировать за выбранный период времени:

·Количество поездок.

·Количество стоянок.

·Общее время продолжительности поездок (с разбивкой по началу и концу каждой поездки).

·Общее время продолжительности стоянок (с разбивкой по началу и концу каждой стоянки).

·Общее количество заправленного топлива.

·Общее количество слитого топлива.

·Время заправок и количество заправленного топлива при каждой заправке.

·Время сливов и количество слитого топлива при каждом сливе.

·Общий расход топлива за выбранный период.

·Средний расход топлива за выбранный период (л/час).

·Общий расход топлива за все поездки.

·Средний расход топлива на всех стоянках (л/час).

·Общий расход топлива по каждой поездке.

·Средний расход топлива по каждой поездке (л/час).

·Общий расход топлива на каждой стоянке.

·Средний расход топлива на каждой стоянке (л/час).

·Количество попаданий техники в ямы.

·Количество недопустимо резких торможений техники.

·Количество недопустимо резких ускорений техники.

·Количество недопустимо резких поворотов, выполненных техникой.

·Количество экстренных ситуаций (опрокидываний) техники.

Необходимое оборудование:

Датчик уровня топлива ДУТ-КВ-Р01 или ДУТ-КВ-Р03 - 1 шт.

Необходимые настройки для получения указанных данных:

Создайте три отчета:

·По топливу. Источник - имеющийся датчик.

·По маршруту. Источник - имеющийся датчик.

·По качеству вождения. Источник - имеющийся датчик.


Техника с большим топливным баком

Имеем: технику с одним большим топливным баком.

Можем контролировать за выбранный период времени:

·Количество поездок.

·Количество стоянок.

·Общее время продолжительности поездок (с разбивкой по началу и концу каждой поездки).

·Общее время продолжительности стоянок (с разбивкой по началу и концу каждой стоянки).

·Общее количество заправленного топлива.

·Общее количество слитого топлива.

·Время заправок и количество заправленного топлива при каждой заправке.

·Время сливов и количество слитого топлива при каждом сливе.

·Общий расход топлива за выбранный период.

·Средний расход топлива за выбранный период (л/час).

·Общий расход топлива за все поездки.

·Средний расход топлива на всех стоянках (л/час).

·Общий расход топлива по каждой поездке.

·Средний расход топлива по каждой поездке (л/час).

·Общий расход топлива на каждой стоянке.

·Средний расход топлива на каждой стоянке (л/час).

·Количество попаданий техники в ямы.

·Количество недопустимо резких торможений техники.

·Количество недопустимо резких ускорений техники.

·Количество недопустимо резких поворотов, выполненных техникой.

·Количество экстренных ситуаций (опрокидываний) техники.

Необходимое оборудование:

Датчик уровня топлива ДУТ-КВ-Р01 или ДУТ-КВ-Р03 - 4 шт.

Все датчики необходимо установить в одном топливном баке, по углам.

Необходимые настройки для получения указанных данных:

1. Создать объединение из всех четырех датчиков.

2. Создайте три отчета:

·По топливу. Источник - среднее значение созданного объединения.

·По маршруту. Источник - любой из четырех датчиков.

·По качеству вождения. Источник - любой из четырех датчиков.


Техника с двумя топливными баками

Имеем: технику с двумя сообщающимися топливными баками.

Можем контролировать за выбранный период времени:

·Количество поездок.

·Количество стоянок.

·Общее время продолжительности поездок (с разбивкой по началу и концу каждой поездки).

·Общее время продолжительности стоянок (с разбивкой по началу и концу каждой стоянки).

·Общее количество заправленного топлива.

·Общее количество слитого топлива.

·Время заправок и количество заправленного топлива при каждой заправке.

·Время сливов и количество слитого топлива при каждом сливе.

·Общий расход топлива за выбранный период.

·Средний расход топлива за выбранный период (л/час).

·Общий расход топлива за все поездки.

·Средний расход топлива на всех стоянках (л/час).

·Общий расход топлива по каждой поездке.

·Средний расход топлива по каждой поездке (л/час).

·Общий расход топлива на каждой стоянке.

·Средний расход топлива на каждой стоянке (л/час).

·Количество попаданий техники в ямы.

·Количество недопустимо резких торможений техники.

·Количество недопустимо резких ускорений техники.

·Количество недопустимо резких поворотов, выполненных техникой.

·Количество экстренных ситуаций (опрокидываний) техники.

Необходимое оборудование:

Датчик уровня топлива ДУТ-КВ-Р01 или ДУТ-КВ-Р03 - 2 шт.

В каждый топливный бак устанавливаем по одному датчику уровня топлива.

Необходимые настройки для получения указанных данных:

1. Создать объединение из этих двух датчиков.

2. Создайте три отчета:

·По топливу. Источник - сумма созданного объединения.

·По маршруту. Источник - любой из двух датчиков.

·По качеству вождения. Источник - любой из двух датчиков.


Техника с двумя топливными баками и баком вспомогательной установки

V.1.2.0 		Top Previous

Имеем: автомобиль с двумя сообщающимися топливными баками + вспомогательная установка с собственным баком (например, буровая установка).

Можем контролировать за выбранный период времени:

- Общие данные:

·Общее количество заправленного топлива: автомобиль+буровая установка.

·Общее количество слитого топлива: автомобиль+буровая установка.

·Общий расход топлива за выбранный период: автомобиль+буровая установка.

·Средний расход топлива за выбранный период: автомобиль+буровая установка (л/час).

- Данные для автомобиля

·Количество поездок.

·Общее время продолжительности поездок (с разбивкой по началу и концу каждой поездки).

·Количество стоянок.

·Общее время продолжительности стоянок (с разбивкой по началу и концу каждой стоянки).

·Общее количество заправленного топлива в бак автомобиля.

·Время заправок и количество заправленного топлива при каждой заправке автомобиля.

·Время сливов и количество слитого топлива при каждом сливе из бака автомобиля.

·Общий расход топлива автомобилем за выбранный период.

·Средний расход топлива автомобилем за выбранный период (л/час).

·Общий расход топлива за все поездки автомобиля.

·Средний расход топлива за все поездки автомобиля (л/час).

·Общий расход топлива по каждой поездке автомобиля.

·Средний расход топлива по каждой поездке автомобиля (л/час).

·Общий расход топлива за все стоянки автомобиля.

·Средний расход топлива за все стоянки автомобиля (л/час).

·Общий расход топлива на каждой стоянке автомобиля.

·Средний расход топлива на каждой стоянке автомобиля (л/час).

·Количество попаданий автомобиля в ямы.

·Количество недопустимо резких торможений автомобиля.

·Количество недопустимо резких ускорений автомобиля.

·Количество недопустимо резких поворотов, выполненных автомобилем.

·Количество экстренных ситуаций (опрокидываний) автомобиля.

- Данные для буровой установки

·Общее количество заправленного топлива в бак буровой установки.

·Время заправок и количество заправленного топлива при каждой заправке в бак буровой установки.

·Время сливов и количество слитого топлива при каждом сливе из бака буровой установки.

·Общий расход топлива буровой установкой за выбранный период.

·Средний расход топлива буровой установкой за выбранный период (л/час).

Необходимое оборудование:

Датчик уровня топлива ДУТ-КВ-Р01 или ДУТ-КВ-Р03 - 3 шт.

В каждый топливный бак устанавливаем по одному датчику уровня топлива.

Необходимые настройки для получения указанных данных:

1. Создать объединения:

- Объединение всех трех датчиков.

- Объединение двух датчиков в баках автомобиля.

2. Создайте отчеты:

·По топливу. Источник - объединение из трех датчиков.

·По топливу. Источник - объединение из двух датчиков.

·По топливу. Источник - датчик уровня топлива буровой установки.

·По маршруту. Источник - любой из датчиков автомобиля.

·По качеству вождения. Источник - любой из датчиков автомобиля.